summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorShlomi Fish <shlomif@shlomifish.org>2017-09-06 23:19:19 +0300
committerZachary Ware <zachary.ware@gmail.com>2017-09-06 13:19:19 -0700
commit6d51b876121e472d4372496d609a26d7e3081c51 (patch)
treefa8c4a3a2e714ab1fbc9dd889b1ebae4abd9f4cb /setup.py
parentc5bace2bf7874cf47ef56e1d8d19f79ad892eef5 (diff)
downloadcpython-git-6d51b876121e472d4372496d609a26d7e3081c51.tar.gz
bpo-30912: Don't check the content of ffi.h (GH-2687)
Various platforms have various methods of handling multiarch libffi which probably won't match the previously looked-for defines. Now we just make sure that ffi.h is available.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 3 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 3c7c9049ed..79f96989a4 100644
--- a/setup.py
+++ b/setup.py
@@ -2021,16 +2021,9 @@ class PyBuildExt(build_ext):
ffi_inc = find_file('ffi.h', [], inc_dirs)
if ffi_inc is not None:
ffi_h = ffi_inc[0] + '/ffi.h'
- with open(ffi_h) as f:
- for line in f:
- line = line.strip()
- if line.startswith(('#define LIBFFI_H',
- '#define ffi_wrapper_h')):
- break
- else:
- ffi_inc = None
- print('Header file {} does not define LIBFFI_H or '
- 'ffi_wrapper_h'.format(ffi_h))
+ if not os.path.exists(ffi_h):
+ ffi_inc = None
+ print('Header file {} does not exist'.format(ffi_h))
ffi_lib = None
if ffi_inc is not None:
for lib_name in ('ffi', 'ffi_pic'):