summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNeil Schemenauer <nas-github@arctrix.com>2017-04-28 09:56:48 -0700
committerGitHub <noreply@github.com>2017-04-28 09:56:48 -0700
commit6c991bdee7ec4bedd8c1b8d3812dc884b654b57c (patch)
tree0401cf8f86a82ee03d41f811942af51117cd9886 /setup.py
parentd1a1def7bf221b04dcf3fc3a67aa19aa2f622f83 (diff)
downloadcpython-git-6c991bdee7ec4bedd8c1b8d3812dc884b654b57c.tar.gz
Check that Python is 64-bit before enabling BLAKE2_USE_SSE. (#1332)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3b3d097454..6a05643838 100644
--- a/setup.py
+++ b/setup.py
@@ -898,8 +898,11 @@ class PyBuildExt(build_ext):
blake2_deps.append('hashlib.h')
blake2_macros = []
- if not cross_compiling and os.uname().machine == "x86_64":
- # Every x86_64 machine has at least SSE2.
+ if (not cross_compiling and
+ os.uname().machine == "x86_64" and
+ sys.maxsize > 2**32):
+ # Every x86_64 machine has at least SSE2. Check for sys.maxsize
+ # in case that kernel is 64-bit but userspace is 32-bit.
blake2_macros.append(('BLAKE2_USE_SSE', '1'))
exts.append( Extension('_blake2',