summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-10 16:45:53 +0100
committerXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-10 16:45:53 +0100
commit13f1c331a5dd5b4ff3b1e4c9e47d6d3ae75e0f8f (patch)
treeac92716b7fe1110c74dc88b51cd9ed681eac7ebe /setup.py
parent21799618ecf3a94c0a93ed56b0ad40af3035ea38 (diff)
downloadcpython-git-13f1c331a5dd5b4ff3b1e4c9e47d6d3ae75e0f8f.tar.gz
Issue #28918: Fix the cross compilation of xxlimited when Python
has been built with Py_DEBUG defined.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index af9a414f7d..116f06fb22 100644
--- a/setup.py
+++ b/setup.py
@@ -1630,7 +1630,7 @@ class PyBuildExt(build_ext):
## ext = Extension('xx', ['xxmodule.c'])
## self.extensions.append(ext)
- if 'd' not in sys.abiflags:
+ if 'd' not in sysconfig.get_config_var('ABIFLAGS'):
ext = Extension('xxlimited', ['xxlimited.c'],
define_macros=[('Py_LIMITED_API', '0x03050000')])
self.extensions.append(ext)