summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-14 11:14:33 +0100
committerXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-14 11:14:33 +0100
commit1351c31aa9651b278d7ef8ec79af3b646a520235 (patch)
tree82c8a8dead962202ac8f9ab1b29b67f0535630e8 /setup.py
parent7262b42fd13bc8ac5b3d2cb9073dda3d3503e831 (diff)
downloadcpython-git-1351c31aa9651b278d7ef8ec79af3b646a520235.tar.gz
Issue #20211: Do not add the directory for installing C header files and
the directory for installing object code libraries to the cross compilation search paths.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 7cb1141dac..d218722e0e 100644
--- a/setup.py
+++ b/setup.py
@@ -532,8 +532,9 @@ class PyBuildExt(build_ext):
for directory in reversed(options.dirs):
add_dir_to_list(dir_list, directory)
- if os.path.normpath(sys.base_prefix) != '/usr' \
- and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
+ if (not cross_compiling and
+ os.path.normpath(sys.base_prefix) != '/usr' and
+ not sysconfig.get_config_var('PYTHONFRAMEWORK')):
# OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
# (PYTHONFRAMEWORK is set) to avoid # linking problems when
# building a framework with different architectures than