diff options
author | Charles-François Natali <neologix@free.fr> | 2012-04-12 19:09:00 +0200 |
---|---|---|
committer | Charles-François Natali <neologix@free.fr> | 2012-04-12 19:09:00 +0200 |
commit | 515ea9bd6568b737c062d9c166bb4c65420bb80a (patch) | |
tree | d1ba5503d3aaff4930a39b5051ae48aa3a7686f3 /setup.py | |
parent | 80a133b91c857f6da41c6eba3b6992af6d696347 (diff) | |
parent | 5739e102ddf62667167da7da878938d64896733d (diff) | |
download | cpython-git-515ea9bd6568b737c062d9c166bb4c65420bb80a.tar.gz |
Issue #14557: Fix extensions build on HP-UX. Patch by Adi Roiban.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 4 insertions, 0 deletions
@@ -464,6 +464,10 @@ class PyBuildExt(build_ext): if platform in ['osf1', 'unixware7', 'openunix8']: lib_dirs += ['/usr/ccs/lib'] + # HP-UX11iv3 keeps files in lib/hpux folders. + if platform == 'hp-ux11': + lib_dirs += ['/usr/lib/hpux64', '/usr/lib/hpux32'] + if platform == 'darwin': # This should work on any unixy platform ;-) # If the user has bothered specifying additional -I and -L flags |