summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAntoine Pitrou <solipsis@pitrou.net>2011-04-03 17:05:46 +0200
committerAntoine Pitrou <solipsis@pitrou.net>2011-04-03 17:05:46 +0200
commit37dc5f85b82292787092dd61b937ee616a2d93b0 (patch)
tree73d2853fc8ee25cbd3e43baa8e2f46a409f6c88f /setup.py
parent0f535013c54955164388d3bf11858b9e42bed39e (diff)
downloadcpython-git-37dc5f85b82292787092dd61b937ee616a2d93b0.tar.gz
Issue #5863: Rewrite BZ2File in pure Python, and allow it to accept
file-like objects using a new `fileobj` constructor argument. Patch by Nadeem Vawda.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index add71ba38e..05e1133639 100644
--- a/setup.py
+++ b/setup.py
@@ -1233,11 +1233,11 @@ class PyBuildExt(build_ext):
bz2_extra_link_args = ('-Wl,-search_paths_first',)
else:
bz2_extra_link_args = ()
- exts.append( Extension('bz2', ['bz2module.c'],
+ exts.append( Extension('_bz2', ['_bz2module.c'],
libraries = ['bz2'],
extra_link_args = bz2_extra_link_args) )
else:
- missing.append('bz2')
+ missing.append('_bz2')
# Interface to the Expat XML parser
#