diff options
author | Skip Montanaro <skip@pobox.com> | 2001-08-21 04:23:21 +0000 |
---|---|---|
committer | Skip Montanaro <skip@pobox.com> | 2001-08-21 04:23:21 +0000 |
commit | e81f447800b1a62140729a00b4f4b56c4e7cc69e (patch) | |
tree | 83a44bb674723bb9161b635b84ac2f7b17a3034b /setup.py | |
parent | d1ed15edb35f61d3ce321b53f3372bc227d150c8 (diff) | |
download | cpython-git-e81f447800b1a62140729a00b4f4b56c4e7cc69e.tar.gz |
This is supposed to help configure better sort out the various libdb
incarnations. It's probably not quite sufficient, but should be better than
the status quo...
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 7 insertions, 1 deletions
@@ -389,7 +389,13 @@ class PyBuildExt(build_ext): # BSD DB 3.x.) dblib = [] - if self.compiler.find_library_file(lib_dirs, 'db'): + if self.compiler.find_library_file(lib_dirs, 'db-3.1'): + dblib = ['db-3.1'] + elif self.compiler.find_library_file(lib_dirs, 'db2'): + dblib = ['db2'] + elif self.compiler.find_library_file(lib_dirs, 'db1'): + dblib = ['db1'] + elif self.compiler.find_library_file(lib_dirs, 'db'): dblib = ['db'] db185_incs = find_file('db_185.h', inc_dirs, |