summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPetri Lehtinen <petri@digip.org>2013-02-23 17:24:00 +0100
committerPetri Lehtinen <petri@digip.org>2013-02-23 17:24:00 +0100
commitd2132144a475bad3676f80d55098b0daba6110f4 (patch)
tree9a97f1d4ecd0b766a942cdacc4ad9386d6360b48 /setup.py
parent18809fa94eb5840421857ed4eabf36f5141fd874 (diff)
parented909bcbddfa9c956fbbbb4a1b6a375d3e0e6599 (diff)
downloadcpython-git-d2132144a475bad3676f80d55098b0daba6110f4.tar.gz
Issue #5033: Fix building of the sqlite3 extension module
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 57dabc10fb..a70909cb50 100644
--- a/setup.py
+++ b/setup.py
@@ -1062,7 +1062,7 @@ class PyBuildExt(build_ext):
with open(f) as file:
incf = file.read()
m = re.search(
- r'\s*.*#\s*.*define\s.*SQLITE_VERSION\W*"(.*)"', incf)
+ r'\s*.*#\s*.*define\s.*SQLITE_VERSION\W*"([\d\.]*)"', incf)
if m:
sqlite_version = m.group(1)
sqlite_version_tuple = tuple([int(x)