summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNick Coghlan <ncoghlan@gmail.com>2012-06-17 18:35:39 +1000
committerNick Coghlan <ncoghlan@gmail.com>2012-06-17 18:35:39 +1000
commit970fcef84bb633e96353de6bf517e4837c90436e (patch)
tree7527bf1c34b9320d199ecd19599853d677167a04 /setup.py
parent43f42fc3cb67433c88e31268767c0cab36422351 (diff)
downloadcpython-git-970fcef84bb633e96353de6bf517e4837c90436e.tar.gz
Issue #15044: Handle Fedora 17's approach to ndbm compatibility (backport from 3.x)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 064bbc0f08..a939b73eda 100644
--- a/setup.py
+++ b/setup.py
@@ -1158,10 +1158,14 @@ class PyBuildExt(build_ext):
for cand in dbm_order:
if cand == "ndbm":
if find_file("ndbm.h", inc_dirs, []) is not None:
- # Some systems have -lndbm, others don't
+ # Some systems have -lndbm, others have -lgdbm_compat,
+ # others don't have either
if self.compiler.find_library_file(lib_dirs,
'ndbm'):
ndbm_libs = ['ndbm']
+ elif self.compiler.find_library_file(lib_dirs,
+ 'gdbm_compat'):
+ ndbm_libs = ['gdbm_compat']
else:
ndbm_libs = []
print "building dbm using ndbm"