summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2013-02-09 17:02:06 +0100
committerChristian Heimes <christian@cheimes.de>2013-02-09 17:02:06 +0100
commit56656b01182a2f480b333d9137908faff10b9ba5 (patch)
tree2b940e4464cecca74c97c46388919538ca31a356 /setup.py
parent276f1d513917bf47e3a9e333529f6b87302d6aaa (diff)
downloadcpython-git-56656b01182a2f480b333d9137908faff10b9ba5.tar.gz
add proper dependencies on expat headers and sources
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 17 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 12eda0a71c..24ce8bce49 100644
--- a/setup.py
+++ b/setup.py
@@ -1449,6 +1449,7 @@ class PyBuildExt(build_ext):
define_macros = []
expat_lib = ['expat']
expat_sources = []
+ expat_depends = []
else:
expat_inc = [os.path.join(os.getcwd(), srcdir, 'Modules', 'expat')]
define_macros = [
@@ -1458,12 +1459,25 @@ class PyBuildExt(build_ext):
expat_sources = ['expat/xmlparse.c',
'expat/xmlrole.c',
'expat/xmltok.c']
+ expat_depends = ['expat/ascii.h',
+ 'expat/asciitab.h',
+ 'expat/expat.h',
+ 'expat/expat_config.h',
+ 'expat/expat_external.h',
+ 'expat/internal.h',
+ 'expat/latin1tab.h',
+ 'expat/utf8tab.h',
+ 'expat/xmlrole.h',
+ 'expat/xmltok.h',
+ 'expat/xmltok_impl.h'
+ ]
exts.append(Extension('pyexpat',
define_macros = define_macros,
include_dirs = expat_inc,
libraries = expat_lib,
- sources = ['pyexpat.c'] + expat_sources
+ sources = ['pyexpat.c'] + expat_sources,
+ depends = expat_depends,
))
# Fredrik Lundh's cElementTree module. Note that this also
@@ -1476,6 +1490,8 @@ class PyBuildExt(build_ext):
include_dirs = expat_inc,
libraries = expat_lib,
sources = ['_elementtree.c'],
+ depends = ['pyexpat.c'] + expat_sources +
+ expat_depends,
))
else:
missing.append('_elementtree')