summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authordoko@ubuntu.com <doko@ubuntu.com>2013-03-19 14:46:29 -0700
committerdoko@ubuntu.com <doko@ubuntu.com>2013-03-19 14:46:29 -0700
commit4950a3b6ccb91e0ffe937374836caa825e93c742 (patch)
treec21a8a4621c1f29eccdebbeca17dbdb0764e20d7 /setup.py
parent868f0aac37cf6c879471c3b8e65e6db623460ce5 (diff)
downloadcpython-git-4950a3b6ccb91e0ffe937374836caa825e93c742.tar.gz
- Issue #17477: Update the bsddb module to pybsddb 5.3.0, supporting
db-5.x, and dropping support for db-4.1 and db-4.2.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 7 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 77edda4a28..ea8a5f51e9 100644
--- a/setup.py
+++ b/setup.py
@@ -878,8 +878,8 @@ class PyBuildExt(build_ext):
# a release. Most open source OSes come with one or more
# versions of BerkeleyDB already installed.
- max_db_ver = (4, 8)
- min_db_ver = (4, 1)
+ max_db_ver = (5, 3)
+ min_db_ver = (4, 3)
db_setup_debug = False # verbose debug prints from this script?
def allow_db_ver(db_ver):
@@ -900,7 +900,11 @@ class PyBuildExt(build_ext):
return True
def gen_db_minor_ver_nums(major):
- if major == 4:
+ if major == 5:
+ for x in range(max_db_ver[1]+1):
+ if allow_db_ver((5, x)):
+ yield x
+ elif major == 4:
for x in range(max_db_ver[1]+1):
if allow_db_ver((4, x)):
yield x