summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authordoko@ubuntu.com <doko@ubuntu.com>2012-09-21 13:51:40 +0200
committerdoko@ubuntu.com <doko@ubuntu.com>2012-09-21 13:51:40 +0200
commit3d2fc15f82f495e6b53a0e7bc60b2283ccbcb5d3 (patch)
tree0d9d2f8fe532c7d5c5ec8846d4ed0f8cc480caf9 /setup.py
parentfb2f409b90cbe8672fdaf574384c66517b6fbe14 (diff)
downloadcpython-git-3d2fc15f82f495e6b53a0e7bc60b2283ccbcb5d3.tar.gz
- Issue #11715: Fix multiarch detection without having Debian development
tools (dpkg-dev) installed.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7b3a535778..1791fbe282 100644
--- a/setup.py
+++ b/setup.py
@@ -351,6 +351,27 @@ class PyBuildExt(build_ext):
def add_multiarch_paths(self):
# Debian/Ubuntu multiarch support.
# https://wiki.ubuntu.com/MultiarchSpec
+ cc = sysconfig.get_config_var('CC')
+ tmpfile = os.path.join(self.build_temp, 'multiarch')
+ if not os.path.exists(self.build_temp):
+ os.makedirs(self.build_temp)
+ ret = os.system(
+ '%s -print-multiarch > %s 2> /dev/null' % (cc, tmpfile))
+ multiarch_path_component = ''
+ try:
+ if ret >> 8 == 0:
+ with open(tmpfile) as fp:
+ multiarch_path_component = fp.readline().strip()
+ finally:
+ os.unlink(tmpfile)
+
+ if multiarch_path_component != '':
+ add_dir_to_list(self.compiler.library_dirs,
+ '/usr/lib/' + multiarch_path_component)
+ add_dir_to_list(self.compiler.include_dirs,
+ '/usr/include/' + multiarch_path_component)
+ return
+
if not find_executable('dpkg-architecture'):
return
tmpfile = os.path.join(self.build_temp, 'multiarch')