summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2013-10-13 23:38:44 +0200
committerGeorg Brandl <georg@python.org>2013-10-13 23:38:44 +0200
commit2852364135f105c1af38fdc378f50d79c6996b38 (patch)
tree11a3e3427bfebb3e36cd9d8ef7081c3c830bc819 /setup.py
parente206e491729b9e531e861d5ef2df1e5fbadb69f4 (diff)
downloadcpython-git-2852364135f105c1af38fdc378f50d79c6996b38.tar.gz
Closes #16732: move "xxmodule" comment block to detect_modules(). (Already done in 3.x)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 8d8ec84d81..bb7f29595d 100644
--- a/setup.py
+++ b/setup.py
@@ -1721,6 +1721,10 @@ class PyBuildExt(build_ext):
if '_tkinter' not in [e.name for e in self.extensions]:
missing.append('_tkinter')
+## # Uncomment these lines if you want to play with xxmodule.c
+## ext = Extension('xx', ['xxmodule.c'])
+## self.extensions.append(ext)
+
return missing
def detect_tkinter_darwin(self, inc_dirs, lib_dirs):
@@ -1911,10 +1915,6 @@ class PyBuildExt(build_ext):
)
self.extensions.append(ext)
-## # Uncomment these lines if you want to play with xxmodule.c
-## ext = Extension('xx', ['xxmodule.c'])
-## self.extensions.append(ext)
-
# XXX handle these, but how to detect?
# *** Uncomment and edit for PIL (TkImaging) extension only:
# -DWITH_PIL -I../Extensions/Imaging/libImaging tkImaging.c \