summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2014-06-25 13:33:57 -0700
committerNed Deily <nad@acm.org>2014-06-25 13:33:57 -0700
commit1f70b878c4b890c66bdb90d8c9ddb59dee0b48df (patch)
tree8116469109a15aa925bff2324f0ed82c18e4d836 /setup.py
parent33ad0968eb624d22075d567123c52f62e7184d8d (diff)
downloadcpython-git-1f70b878c4b890c66bdb90d8c9ddb59dee0b48df.tar.gz
Issue #21811: Anticipated fixes to 3.x and 2.7 for OS X 10.10 Yosemite.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2b4119a413..a46bf35eb4 100644
--- a/setup.py
+++ b/setup.py
@@ -733,7 +733,9 @@ class PyBuildExt(build_ext):
if host_platform == 'darwin':
os_release = int(os.uname()[2].split('.')[0])
dep_target = sysconfig.get_config_var('MACOSX_DEPLOYMENT_TARGET')
- if dep_target and dep_target.split('.') < ['10', '5']:
+ if (dep_target and
+ (tuple(int(n) for n in dep_target.split('.')[0:2])
+ < (10, 5) ) ):
os_release = 8
if os_release < 9:
# MacOSX 10.4 has a broken readline. Don't try to build