summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCharles-François Natali <neologix@free.fr>2012-04-12 19:11:54 +0200
committerCharles-François Natali <neologix@free.fr>2012-04-12 19:11:54 +0200
commit0d3db3a8157f38e6dc7ea69500069c86c0b40be7 (patch)
treeb8aadb1408ebe4a720e89a222c1d1115f3991b12 /setup.py
parent142ab32ecdc8ee1e602534501653121bb3cd0d0d (diff)
downloadcpython-git-0d3db3a8157f38e6dc7ea69500069c86c0b40be7.tar.gz
Issue #14557: Fix extensions build on HP-UX. Patch by Adi Roiban.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 2c1473c8bb..064bbc0f08 100644
--- a/setup.py
+++ b/setup.py
@@ -451,6 +451,10 @@ class PyBuildExt(build_ext):
if platform in ['osf1', 'unixware7', 'openunix8']:
lib_dirs += ['/usr/ccs/lib']
+ # HP-UX11iv3 keeps files in lib/hpux folders.
+ if platform == 'hp-ux11':
+ lib_dirs += ['/usr/lib/hpux64', '/usr/lib/hpux32']
+
if platform == 'darwin':
# This should work on any unixy platform ;-)
# If the user has bothered specifying additional -I and -L flags