summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Heller <theller@ctypes.org>2010-08-08 17:56:41 +0000
committerThomas Heller <theller@ctypes.org>2010-08-08 17:56:41 +0000
commit001d3a1d8ac9b5a057a585950182880f5733c608 (patch)
treefc83b45c8370714c94522d12b1f1a319fe23408d /setup.py
parent6fe8c41e8ff4d87fd6bb1bc9ae67d0f49b5073f4 (diff)
downloadcpython-git-001d3a1d8ac9b5a057a585950182880f5733c608.tar.gz
Fis issue5504: ctypes does now work with systems where mmap can't be
PROT_WRITE and PROT_EXEC.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index a363509fbd..7d5d30c2cb 100644
--- a/setup.py
+++ b/setup.py
@@ -1867,8 +1867,7 @@ class PyBuildExt(build_ext):
'_ctypes/callbacks.c',
'_ctypes/callproc.c',
'_ctypes/stgdict.c',
- '_ctypes/cfield.c',
- '_ctypes/malloc_closure.c']
+ '_ctypes/cfield.c']
depends = ['_ctypes/ctypes.h']
if sys.platform == 'darwin':