summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2006-02-27 15:16:21 +0000
committerMartin v. Löwis <martin@v.loewis.de>2006-02-27 15:16:21 +0000
commit2086eaf79c9dc2992fef64392a9813e25f60696f (patch)
tree2b2aa762db32ade74b34e87ebb01ebdf6565391f /setup.py
parent322a23f21b78ffbdf4da3330082a04db093af0af (diff)
downloadcpython-git-2086eaf79c9dc2992fef64392a9813e25f60696f.tar.gz
Check for a not-found rlconf.h by testing for None.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 149b9403c4..5ff13c00a1 100644
--- a/setup.py
+++ b/setup.py
@@ -452,7 +452,7 @@ class PyBuildExt(build_ext):
# MacOSX 10.4 has a broken readline. Don't try to build
# the readline module unless the user has installed a fixed
# readline package
- if not find_file('readline/rlconf.h', inc_dirs, []):
+ if find_file('readline/rlconf.h', inc_dirs, []) is None:
do_readline = False
if do_readline:
readline_libs = ['readline']