summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRaymond Hettinger <python@rcn.com>2004-01-29 06:37:52 +0000
committerRaymond Hettinger <python@rcn.com>2004-01-29 06:37:52 +0000
commit756b3f3c15bd314ffa25299ca25465ae21e62a30 (patch)
treef504d3ab53c151b7e88ebfebd069a034f80f5025 /setup.py
parent141d4e564314abde44189eb5e3a9f509dab045ff (diff)
downloadcpython-git-756b3f3c15bd314ffa25299ca25465ae21e62a30.tar.gz
* Move collections.deque() in from the sandbox
* Add unittests, newsitem, and whatsnew * Apply to Queue.py mutex.py threading.py pydoc.py and shlex.py * Docs are forthcoming
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7e2fdd4b0b..8439ef45f0 100644
--- a/setup.py
+++ b/setup.py
@@ -322,6 +322,8 @@ class PyBuildExt(build_ext):
exts.append( Extension("_random", ["_randommodule.c"]) )
# fast iterator tools implemented in C
exts.append( Extension("itertools", ["itertoolsmodule.c"]) )
+ # high-performance collections
+ exts.append( Extension("collections", ["collectionsmodule.c"]) )
# bisect
exts.append( Extension("_bisect", ["_bisectmodule.c"]) )
# heapq