summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2021-09-29 07:35:53 -0700
committerGitHub <noreply@github.com>2021-09-29 16:35:53 +0200
commit90004fca1cc3c6e3c9b2c3faae5cb1b7d7711648 (patch)
treee99eabb3712f13118902746a2325f86b76b1911c /setup.py
parent456d6d9fefac828c19fc1b562f6301f00965fe59 (diff)
downloadcpython-git-90004fca1cc3c6e3c9b2c3faae5cb1b7d7711648.tar.gz
[3.8] bpo-44394: Ensure libexpat is linked against libm (GH-28617) (GH-28620)
(cherry picked from commit 6c1154b9de29e1c9cd3d05f5289543e5cff73895) Co-authored-by: Pablo Galindo Salgado <Pablogsal@gmail.com> Co-authored-by: Ɓukasz Langa <lukasz@langa.pl>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2d6b05682d..57be07a7e0 100644
--- a/setup.py
+++ b/setup.py
@@ -1578,7 +1578,9 @@ class PyBuildExt(build_ext):
('XML_POOR_ENTROPY', '1'),
]
extra_compile_args = []
- expat_lib = []
+ # bpo-44394: libexpat uses isnan() of math.h and needs linkage
+ # against the libm
+ expat_lib = ['m']
expat_sources = ['expat/xmlparse.c',
'expat/xmlrole.c',
'expat/xmltok.c']