summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-01-17 19:27:57 +0000
committerRonald Oussoren <ronaldoussoren@mac.com>2010-01-17 19:27:57 +0000
commit3c0a1265c19c6fa676f6f632fb2e9bc773fb4abc (patch)
tree4999584b309706e114430d44c30deb45c10ccb44 /configure.in
parenta55af9a9db334fb587f2c6b37ac28ac2463ebf04 (diff)
downloadcpython-git-3c0a1265c19c6fa676f6f632fb2e9bc773fb4abc.tar.gz
This patch ensures that the configure-script mentions checking for --enable-universalsdk
and that it doesn't default to the 10.4u SDK when that SDK does not exist. (This affects OSX) This patch should fix most of issue 4834, although I haven't gotten enough information from the user to be sure.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 16a743e910..b3649cf416 100644
--- a/configure.in
+++ b/configure.in
@@ -86,12 +86,17 @@ define_xopen_source=yes
AC_SUBST(CONFIG_ARGS)
CONFIG_ARGS="$ac_configure_args"
+AC_MSG_CHECKING([for --enable-universalsdk])
AC_ARG_ENABLE(universalsdk,
AC_HELP_STRING(--enable-universalsdk@<:@=SDKDIR@:>@, Build against Mac OS X 10.4u SDK (ppc/i386)),
[
case $enableval in
yes)
enableval=/Developer/SDKs/MacOSX10.4u.sdk
+ if test ! -d "${enableval}"
+ then
+ enableval=/
+ fi
;;
esac
case $enableval in
@@ -101,12 +106,23 @@ AC_ARG_ENABLE(universalsdk,
;;
*)
UNIVERSALSDK=$enableval
+ if test ! -d "${UNIVERSALSDK}"
+ then
+ AC_MSG_ERROR([--enable-universalsdk specifies non-existing SDK: ${UNIVERSALSDK}])
+ fi
;;
esac
+
],[
UNIVERSALSDK=
enable_universalsdk=
])
+if test -n "${UNIVERSALSDK}"
+then
+ AC_MSG_RESULT(${UNIVERSALSDK})
+else
+ AC_MSG_RESULT(no)
+fi
AC_SUBST(UNIVERSALSDK)
AC_SUBST(ARCH_RUN_32BIT)