summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Carlier <dcarlier@afilias.info>2018-01-09 19:38:07 +0000
committerAntoine Pitrou <pitrou@free.fr>2018-01-09 20:38:07 +0100
commitb4ebaa7099c3413b42a97777581c4ca560fe7540 (patch)
treebbcd366879bb2595307e5a1305de5e2fd954bf5f /configure.ac
parent2ab3a8fd264f24baf321b861a997bf8848f232d5 (diff)
downloadcpython-git-b4ebaa7099c3413b42a97777581c4ca560fe7540.tar.gz
bpo-32493: Not only AIX, but FreeBSD has uuid_create support (#5089)
Allow building the _uuid extension module on FreeBSD and OpenBSD.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0a48e41d5c..1894e21f30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2696,13 +2696,14 @@ void *x = uuid_generate_time_safe
)
# AIX provides support for RFC4122 (uuid) in libc.a starting with AIX 6.1 (anno 2007)
-AC_MSG_CHECKING(for RFC4122 - uuid support on AIX)
+# FreeBSD and OpenBSD provides support as well
+AC_MSG_CHECKING(for uuid_create)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <uuid.h>]], [[
#ifndef uuid_create
void *x = uuid_create
#endif
]])],
- [AC_DEFINE(HAVE_UUID_CREATE, 1, Define if uuid_create() exists. AIX support for uuid:RFC4122)
+ [AC_DEFINE(HAVE_UUID_CREATE, 1, Define if uuid_create() exists.)
AC_MSG_RESULT(yes)],
[AC_MSG_RESULT(no)]
)