summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBerker Peksag <berker.peksag@gmail.com>2017-11-08 23:09:16 +0300
committerGitHub <noreply@github.com>2017-11-08 23:09:16 +0300
commit9a10ff4deb2494e22bc0dbea3e3a6f9e8354d995 (patch)
treed860e1b145cf9e9e144ada162d731bb5ea78108d /configure.ac
parentbf9d317626eebcf79bd0756b4dd43df82d5cc186 (diff)
downloadcpython-git-9a10ff4deb2494e22bc0dbea3e3a6f9e8354d995.tar.gz
bpo-11063: Add a configure check for uuid_generate_time_safe (GH-4287)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c773806458..743e0625dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2677,6 +2677,18 @@ AC_CHECK_LIB(sendfile, sendfile)
AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
+AC_MSG_CHECKING(for uuid_generate_time_safe)
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <uuid/uuid.h>]], [[
+#ifndef uuid_generate_time_safe
+uuid_t out;
+uuid_generate_time_safe(out);
+#endif
+]])],
+ [AC_DEFINE(HAVE_UUID_GENERATE_TIME_SAFE, 1, Define if uuid_generate_time_safe() exists.)
+ AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)]
+)
+
AC_SEARCH_LIBS(sem_init, pthread rt posix4) # 'Real Time' functions on Solaris
# posix4 on Solaris 2.6
# pthread (first!) on Linux