summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@python.org>2018-01-30 07:42:14 -0500
committerGitHub <noreply@github.com>2018-01-30 07:42:14 -0500
commit8c9bb72e8b6474ae722f7d6521cfb3cb2e26e3c5 (patch)
tree56be57eb0b019da69cbbe6a1c089e07291f81e9b /configure.ac
parentb8d90328ad2abc9d6d2c9b8ce769fb82b18bbc10 (diff)
downloadcpython-git-8c9bb72e8b6474ae722f7d6521cfb3cb2e26e3c5.tar.gz
bpo-32726: macOS installer and framework enhancements and changes for 3.7.0 (GH-5448)
This issue covers various changes for the macOS installers provided via python.org for 3.7.0. - Provide a provisional new installer variant for macOS 10.9 and later systems with 64-bit (x86_64) architecture only. Apple has made it known that future versions of macOS will only fully support 64-bit executables and some other third-party software suppliers have chosen 10.9 as their oldest supported system. - Support **Tcl/Tk 8.6** with the 10.9 installer variant. - Upgrade **OpenSSL** to 1.1.0g and **SQLite** to 3.22.0. - The compiler name used for the interpreter build and for modules built with **Distutils / pip** is now _gcc_ rather than _gcc-4.2_. And extension module builds will no longer try to force use of an old SDK if present.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index af10a6d3ca..525e572c1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,7 +212,7 @@ fi
AC_SUBST(LIPO_32BIT_FLAGS)
AC_MSG_CHECKING(for --with-universal-archs)
AC_ARG_WITH(universal-archs,
- AS_HELP_STRING([--with-universal-archs=ARCH], [select architectures for universal build ("32-bit", "64-bit", "3-way", "intel", "intel-32", or "all")]),
+ AS_HELP_STRING([--with-universal-archs=ARCH], [select architectures for universal build ("32-bit", "64-bit", "3-way", "intel", "intel-32", "intel-64", or "all")]),
[
UNIVERSAL_ARCHS="$withval"
],
@@ -1768,6 +1768,11 @@ yes)
LIPO_32BIT_FLAGS=""
ARCH_RUN_32BIT=""
;;
+ intel-64)
+ UNIVERSAL_ARCH_FLAGS="-arch x86_64"
+ LIPO_32BIT_FLAGS=""
+ ARCH_RUN_32BIT="true"
+ ;;
3-way)
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch x86_64"
LIPO_32BIT_FLAGS="-extract ppc7400 -extract i386"
@@ -1778,11 +1783,14 @@ yes)
;;
esac
- CFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${CFLAGS}"
- LDFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${LDFLAGS}"
if test "${UNIVERSALSDK}" != "/"
then
+ CFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${CFLAGS}"
+ LDFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${LDFLAGS}"
CPPFLAGS="-isysroot ${UNIVERSALSDK} ${CPPFLAGS}"
+ else
+ CFLAGS="${UNIVERSAL_ARCH_FLAGS} ${CFLAGS}"
+ LDFLAGS="${UNIVERSAL_ARCH_FLAGS} ${LDFLAGS}"
fi
fi