summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSerhiy Storchaka <storchaka@gmail.com>2017-11-01 14:34:20 +0200
committerGitHub <noreply@github.com>2017-11-01 14:34:20 +0200
commit894ebd065e02debf20c0657d26020ecc42b7534f (patch)
tree53809e5ad863135e94a77da6825448341f00d65a /configure.ac
parent388cd85e51aa9c73f8e7f35f0d06c258be7b579c (diff)
downloadcpython-git-894ebd065e02debf20c0657d26020ecc42b7534f.tar.gz
bpo-31919: Fix building the curses module on OpenIndiana. (#4211)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 724f7ce64c..fd15868166 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5033,6 +5033,17 @@ void *x=syncok
[AC_MSG_RESULT(no)]
)
+AC_MSG_CHECKING(for wchgat)
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <curses.h>]], [[
+#ifndef wchgat
+void *x=wchgat
+#endif
+]])],
+ [AC_DEFINE(HAVE_CURSES_WCHGAT, 1, Define if you have the 'wchgat' function.)
+ AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)]
+)
+
AC_MSG_CHECKING(for filter)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <curses.h>]], [[
#ifndef filter