summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorxdegaye <xdegaye@gmail.com>2017-11-23 12:01:36 +0100
committerGitHub <noreply@github.com>2017-11-23 12:01:36 +0100
commit5ce1069a6ff0d5443074d33ba1d403ccd2eaf3d3 (patch)
tree5e7be2f6a553b139ffe871236ed772fa34d4a81b /configure.ac
parentc06c22e9a9fb9326e79fcf1551601eacc1fd457d (diff)
downloadcpython-git-5ce1069a6ff0d5443074d33ba1d403ccd2eaf3d3.tar.gz
bpo-28762: Revert last commit (now using Android Unified Headers) (GH-4488)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 6a69f789fe..68a95c3be6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3415,7 +3415,7 @@ AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
getgrouplist getgroups getlogin getloadavg getpeername getpgid getpid \
getpriority getresuid getresgid getpwent getspnam getspent getsid getwd \
if_nameindex \
- initgroups kill killpg lchmod lchown linkat lstat lutimes mmap \
+ initgroups kill killpg lchmod lchown lockf linkat lstat lutimes mmap \
memrchr mbrtowc mkdirat mkfifo \
mkfifoat mknod mknodat mktime mremap nice openat pathconf pause pipe2 plock poll \
posix_fallocate posix_fadvise pread \
@@ -3764,15 +3764,6 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
AC_MSG_RESULT(no)
])
-# Issue #28762: lockf() is available on Android API level 24, but the F_LOCK
-# macro is not defined in android-ndk-r13.
-AC_MSG_CHECKING(for lockf)
-AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <unistd.h> ]],[[lockf(0, F_LOCK, 0);]])],
- [AC_DEFINE(HAVE_LOCKF, 1, Define to 1 if you have the 'lockf' function and the F_LOCK macro.)
- AC_MSG_RESULT(yes)],
- [AC_MSG_RESULT(no)
-])
-
# On OSF/1 V5.1, getaddrinfo is available, but a define
# for [no]getaddrinfo in netdb.h.
AC_MSG_CHECKING(for getaddrinfo)