summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorxdegaye <xdegaye@gmail.com>2017-11-23 11:13:22 +0100
committerGitHub <noreply@github.com>2017-11-23 11:13:22 +0100
commit5ad7ef8e420de8a54fb30ed37362194c6b96012c (patch)
tree08440fd7f7190758ebd168a8e930cbc30ce93619 /configure.ac
parent1f15111a6e15d52f6b08907576ec61493cd59358 (diff)
downloadcpython-git-5ad7ef8e420de8a54fb30ed37362194c6b96012c.tar.gz
bpo-28538: Revert all the changes (now using Android Unified Headers) (GH-4479)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 1 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 3464212edd..501f07892f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3411,6 +3411,7 @@ AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
futimens futimes gai_strerror getentropy \
getgrouplist getgroups getlogin getloadavg getpeername getpgid getpid \
getpriority getresuid getresgid getpwent getspnam getspent getsid getwd \
+ if_nameindex \
initgroups kill killpg lchmod lchown linkat lstat lutimes mmap \
memrchr mbrtowc mkdirat mkfifo \
mkfifoat mknod mknodat mktime mremap nice openat pathconf pause pipe2 plock poll \
@@ -3760,31 +3761,6 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
AC_MSG_RESULT(no)
])
-# On Android API level 24 with android-ndk-r13, if_nameindex() is available,
-# but the if_nameindex structure is not defined.
-AC_MSG_CHECKING(for if_nameindex)
-AC_LINK_IFELSE([AC_LANG_PROGRAM([[
-#include <stdio.h>
-#ifdef STDC_HEADERS
-# include <stdlib.h>
-# include <stddef.h>
-#else
-# ifdef HAVE_STDLIB_H
-# include <stdlib.h>
-# endif
-#endif
-#ifdef HAVE_SYS_SOCKET_H
-# include <sys/socket.h>
-#endif
-#ifdef HAVE_NET_IF_H
-# include <net/if.h>
-#endif
-]], [[struct if_nameindex *ni = if_nameindex(); int x = ni[0].if_index;]])],
- [AC_DEFINE(HAVE_IF_NAMEINDEX, 1, Define to 1 if you have the 'if_nameindex' function.)
- AC_MSG_RESULT(yes)],
- [AC_MSG_RESULT(no)
-])
-
# Issue #28762: lockf() is available on Android API level 24, but the F_LOCK
# macro is not defined in android-ndk-r13.
AC_MSG_CHECKING(for lockf)