summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2019-04-29 12:27:36 -0700
committerGitHub <noreply@github.com>2019-04-29 12:27:36 -0700
commit52a5b71063af68c42b048095c4e555e93257f151 (patch)
tree910ffece0b32380f1228ae6f8d6ae4731adc9318 /configure.ac
parent5e09a9973b46cd6361a25877e0ca8dd0ab82d678 (diff)
downloadcpython-git-52a5b71063af68c42b048095c4e555e93257f151.tar.gz
bpo-34602: Avoid failures setting macOS stack resource limit (GH-13011)
Under some conditions the earlier fix for bpo-18075, "Infinite recursion tests triggering a segfault on Mac OS X", now causes failures on macOS when attempting to change stack limit with resource.setrlimit resource.RLIMIT_STACK, like regrtest does when running the test suite. The reverted change had specified a non-default stack size when linking the python executable on macOS. As of macOS 10.14.4, the previous code causes a hard failure when running tests, although similar failures had been seen under some conditions under some earlier systems. For now, revert the original change and resume using the default stack size when linking the interpreter. (cherry picked from commit 883dfc668f9730b00928730035b5dbd24b9da2a0) Co-authored-by: Ned Deily <nad@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index e5fb7e7b0b..97745aa112 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2708,12 +2708,6 @@ then
# -u libsys_s pulls in all symbols in libsys
Darwin/*)
LINKFORSHARED="$extra_undefs -framework CoreFoundation"
-
- # Issue #18075: the default maximum stack size (8MBytes) is too
- # small for the default recursion limit. Increase the stack size
- # to ensure that tests don't crash
- LINKFORSHARED="-Wl,-stack_size,1000000 $LINKFORSHARED"
-
if test "$enable_framework"
then
LINKFORSHARED="$LINKFORSHARED "'$(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'