summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2018-08-24 12:36:30 -0400
committerGitHub <noreply@github.com>2018-08-24 12:36:30 -0400
commit4973f767891e8eb14925a58313085e14cf6ea621 (patch)
tree0dfe77b498d11756798735a3790c0bdb8b009f81 /configure.ac
parentc7f543520161b895796a571881da74e805d0b1eb (diff)
downloadcpython-git-4973f767891e8eb14925a58313085e14cf6ea621.tar.gz
bpo-34448: Improve output of usable wchar_t check (GH-8846)
(cherry picked from commit 3738fadc670274ecc4649f51b52a93602820a375) Co-authored-by: Michael Osipov <1983-01-06@gmx.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e6ebb43e7f..2b8aa4d592 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4621,19 +4621,19 @@ then
AC_MSG_RESULT($ac_cv_wchar_t_signed)
fi
+AC_MSG_CHECKING(whether wchar_t is usable)
# wchar_t is only usable if it maps to an unsigned type
if test "$ac_cv_sizeof_wchar_t" -ge 2 \
-a "$ac_cv_wchar_t_signed" = "no"
then
- HAVE_USABLE_WCHAR_T="yes"
AC_DEFINE(HAVE_USABLE_WCHAR_T, 1,
[Define if you have a useable wchar_t type defined in wchar.h; useable
means wchar_t must be an unsigned type with at least 16 bits. (see
Include/unicodeobject.h).])
+ AC_MSG_RESULT(yes)
else
- HAVE_USABLE_WCHAR_T="no usable wchar_t found"
+ AC_MSG_RESULT(no)
fi
-AC_MSG_RESULT($HAVE_USABLE_WCHAR_T)
# check for endianness
AC_C_BIGENDIAN