summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2018-07-15 17:44:11 -0700
committerGitHub <noreply@github.com>2018-07-15 17:44:11 -0700
commit3fc12f0e2ad9ba49243f5a43a8803018b2ff5904 (patch)
treed394b826126a7fb602404e801a355105e31b69b2 /configure.ac
parentc721472fb83d1f7c7606bcf33ba2d42d6127a764 (diff)
downloadcpython-git-3fc12f0e2ad9ba49243f5a43a8803018b2ff5904.tar.gz
bpo-34121: Fix detection of C11 atomic support on clang. (GH-8288)
(cherry picked from commit 15c7b2abdfb93f8902dd72474818aee2bf97fa66) Co-authored-by: Benjamin Peterson <benjamin@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ecb633b763..b7edbf322a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5413,7 +5413,6 @@ AC_LINK_IFELSE(
AC_LANG_SOURCE([[
#include <stdatomic.h>
atomic_int value = ATOMIC_VAR_INIT(1);
- _Atomic void *py_atomic_address = (void*) &value;
int main() {
int loaded_value = atomic_load(&value);
return 0;
@@ -5425,7 +5424,7 @@ AC_MSG_RESULT($have_stdatomic_h)
if test "$have_stdatomic_h" = yes; then
AC_DEFINE(HAVE_STD_ATOMIC, 1,
- [Has stdatomic.h, atomic_int and _Atomic void* types work])
+ [Has stdatomic.h with atomic_int])
fi
# Check for GCC >= 4.7 __atomic builtins