summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2018-09-12 22:33:02 -0700
committerGitHub <noreply@github.com>2018-09-12 22:33:02 -0700
commit35c94c765bf46e93a0d84e39dbc6eaaba40b1f36 (patch)
tree69bf5113b64537f9d881f7afef015541c424cc8a /configure.ac
parent90f7d455b7f4bd53d3af11cb951347c9c8230399 (diff)
downloadcpython-git-35c94c765bf46e93a0d84e39dbc6eaaba40b1f36.tar.gz
bpo-34652: Remove lchmod from the big func checking block. (GH-9247)
A fix for 883702ebb8bbfa749ef0040d1b58d6222bf589ee. (cherry picked from commit ed709d5699716bf7237856dc20aba321e2dfff6d) Co-authored-by: Benjamin Peterson <benjamin@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d7e0de3a32..0cd1b78cf7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3503,7 +3503,7 @@ AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
getgrouplist getgroups getlogin getloadavg getpeername getpgid getpid \
getpriority getresuid getresgid getpwent getspnam getspent getsid getwd \
if_nameindex \
- initgroups kill killpg lchmod lchown lockf linkat lstat lutimes mmap \
+ initgroups kill killpg lchown lockf linkat lstat lutimes mmap \
memrchr mbrtowc mkdirat mkfifo \
mkfifoat mknod mknodat mktime mremap nice openat pathconf pause pipe2 plock poll \
posix_fallocate posix_fadvise posix_spawn pread preadv preadv2 \
@@ -3523,7 +3523,7 @@ AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
# links. Some libc implementations have a stub lchmod implementation that always
# returns an error.
if test "$MACHDEP" != linux; then
- AC_CHECK_FUNC(lchmod)
+ AC_CHECK_FUNCS(lchmod)
fi
AC_CHECK_DECL(dirfd,