summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2019-02-25 21:59:14 -0800
committerGitHub <noreply@github.com>2019-02-25 21:59:14 -0800
commit2055ebb940a737b1375435209c37eae535f062f9 (patch)
tree82d5df864ce4fc73a3b60fdbc7376dc09ba2dedf /configure.ac
parent0b3019a02e60171e9b7edb261e1234109001819c (diff)
downloadcpython-git-2055ebb940a737b1375435209c37eae535f062f9.tar.gz
closes bpo-13497: Fix `broken nice` configure test. (GH-12041)
Per POSIX, `nice(3)` requires `unistd.h` and `exit(3)` requires `stdlib.h`. Fixing the test will prevent false positives with pedantic compilers like clang. (cherry picked from commit 90c6facebd5666fec85f125ee2795b48b30319a4) Co-authored-by: ngie-eign <1574099+ngie-eign@users.noreply.github.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 788c361ffe..ad0f4d42b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4890,6 +4890,8 @@ LIBS=$LIBS_no_readline
AC_MSG_CHECKING(for broken nice())
AC_CACHE_VAL(ac_cv_broken_nice, [
AC_RUN_IFELSE([AC_LANG_SOURCE([[
+#include <stdlib.h>
+#include <unistd.h>
int main()
{
int val1 = nice(1);