summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2018-08-20 10:48:31 -0400
committerGitHub <noreply@github.com>2018-08-20 10:48:31 -0400
commit2011dd77b6bd6f02f54ceef9a80a22bd373b66e2 (patch)
treead1fb37e8ec6545ae533a4ca31902965c538b821 /configure.ac
parent1e596d3a20a1a9d1ef15218ef33795bc9e651b7a (diff)
downloadcpython-git-2011dd77b6bd6f02f54ceef9a80a22bd373b66e2.tar.gz
bpo-30411: Use --git-dir instead of -C to make git work under version below 1.8.5. (GH-8744)
(cherry picked from commit 4c8555773a801f957297132a92c0acb382d640e4) Co-authored-by: Xiang Zhang <angwerzx@126.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b7edbf322a..e6ebb43e7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,9 +39,9 @@ HAS_GIT=no-repository
fi
if test $HAS_GIT = found
then
- GITVERSION="git -C \$(srcdir) rev-parse --short HEAD"
- GITTAG="git -C \$(srcdir) describe --all --always --dirty"
- GITBRANCH="git -C \$(srcdir) name-rev --name-only HEAD"
+ GITVERSION="git --git-dir \$(srcdir)/.git rev-parse --short HEAD"
+ GITTAG="git --git-dir \$(srcdir)/.git describe --all --always --dirty"
+ GITBRANCH="git --git-dir \$(srcdir)/.git name-rev --name-only HEAD"
else
GITVERSION=""
GITTAG=""