summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2018-12-04 07:06:16 -0800
committerGitHub <noreply@github.com>2018-12-04 07:06:16 -0800
commit1751423686d05e3facdd6da2620202728e5d7917 (patch)
treec9232bd1940ea09de1afa861d9f616af874c330d /configure.ac
parent12735c14134082584b899308af8dd8fcc9f15696 (diff)
downloadcpython-git-1751423686d05e3facdd6da2620202728e5d7917.tar.gz
bpo-35351: Pass link time optimization flags to CFLAGS_NODIST (GH-10797)
When using link time optimizations, the -flto flag is passed to BASECFLAGS, which makes it propagate to distutils. Those flags should be reserved for the interpreter and the stdlib extension modules only, thus moving those flags to CFLAGS_NODIST. (cherry picked from commit f92c7aa1ae81efa475b5aecf66e4711ef0f52c4c) Co-authored-by: stratakis <cstratak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 320671edad..c35aea98e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1394,7 +1394,7 @@ if test "$Py_LTO" = 'true' ; then
LTOFLAGS="$LTOFLAGS -g"
fi
- BASECFLAGS="$BASECFLAGS $LTOFLAGS"
+ CFLAGS_NODIST="$CFLAGS_NODIST $LTOFLAGS"
LDFLAGS="$LDFLAGS $LTOFLAGS"
fi