summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@python.org>2017-10-09 13:53:27 -0400
committerGitHub <noreply@github.com>2017-10-09 13:53:27 -0400
commit14aa00b519c827578648f2c006ad0ac8058cf6a1 (patch)
tree0e04d5f566ae137ab31bd2a81ef446aee9ababe2 /configure.ac
parent6e3d6b5dc22cd06d8c4d44a38a8a3415e4bebb16 (diff)
downloadcpython-git-14aa00b519c827578648f2c006ad0ac8058cf6a1.tar.gz
Allow configure to handle PATH elements with spaces (#3935)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a3114be738..bf2b7c0753 100644
--- a/configure.ac
+++ b/configure.ac
@@ -621,14 +621,14 @@ then
for as_dir in $PATH
do
IFS=$as_save_IFS
- if test -x $as_dir/gcc; then
+ if test -x "${as_dir}/gcc"; then
if test -z "${found_gcc}"; then
- found_gcc=$as_dir/gcc
+ found_gcc="${as_dir}/gcc"
fi
fi
- if test -x $as_dir/clang; then
+ if test -x "${as_dir}/clang"; then
if test -z "${found_clang}"; then
- found_clang=$as_dir/clang
+ found_clang="${as_dir}/clang"
fi
fi
done