summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBerker Peksag <berker.peksag@gmail.com>2017-11-09 00:43:14 +0300
committerGitHub <noreply@github.com>2017-11-09 00:43:14 +0300
commit0e163d2ced28ade8ff526e8c663faf03c2c0b168 (patch)
treeb799d4d5191b70038c83f82bca999fbd686d5113 /configure.ac
parent9a10ff4deb2494e22bc0dbea3e3a6f9e8354d995 (diff)
downloadcpython-git-0e163d2ced28ade8ff526e8c663faf03c2c0b168.tar.gz
bpo-11063: Use more reliable way to check if uuid function exists (GH-4343)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 743e0625dc..1a309c813a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2680,8 +2680,7 @@ AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
AC_MSG_CHECKING(for uuid_generate_time_safe)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <uuid/uuid.h>]], [[
#ifndef uuid_generate_time_safe
-uuid_t out;
-uuid_generate_time_safe(out);
+void *x = uuid_generate_time_safe
#endif
]])],
[AC_DEFINE(HAVE_UUID_GENERATE_TIME_SAFE, 1, Define if uuid_generate_time_safe() exists.)