summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2018-07-11 07:48:42 -0700
committerGitHub <noreply@github.com>2018-07-11 07:48:42 -0700
commit020f5ab7170836b277ac8fef2ce7438ae0145caf (patch)
treef08b9648fd0f61950ce31c04a7aadf0519725432 /configure.ac
parent0a1db32949b4813e9ac04e672fcb5bc97072a428 (diff)
downloadcpython-git-020f5ab7170836b277ac8fef2ce7438ae0145caf.tar.gz
bpo-33648: Remove PY_WARN_ON_C_LOCALE (GH-7114)
This code does not appear to be used anywhere in the python code base. The use was removed in eb81795d7d3a8c898fa89. (cherry picked from commit b91a3a0d61596cafb1b46c98fab65fee16a8bbbb) Co-authored-by: Eitan Adler <grimreaper@users.noreply.github.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 3885786aab..ecb633b763 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3385,23 +3385,6 @@ then
fi
AC_MSG_RESULT($with_c_locale_coercion)
-# Check for --with-c-locale-warning
-AC_MSG_CHECKING(for --with-c-locale-warning)
-AC_ARG_WITH(c-locale-warning,
- AS_HELP_STRING([--with(out)-c-locale-warning],
- [disable/enable locale compatibility warning in the C locale]))
-
-if test -z "$with_c_locale_warning"
-then
- with_c_locale_warning="yes"
-fi
-if test "$with_c_locale_warning" != "no"
-then
- AC_DEFINE(PY_WARN_ON_C_LOCALE, 1,
- [Define to emit a locale compatibility warning in the C locale])
-fi
-AC_MSG_RESULT($with_c_locale_warning)
-
# Check for Valgrind support
AC_MSG_CHECKING([for --with-valgrind])
AC_ARG_WITH([valgrind],