summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorstratakis <cstratak@redhat.com>2018-12-19 18:19:01 +0100
committerVictor Stinner <vstinner@redhat.com>2018-12-19 18:19:01 +0100
commitcf10a750f4b50b6775719cfb17bee00bc3a9c60b (patch)
treeb01cd3a429404cf2a2d58d8cfb35676c8969f5f6 /configure.ac
parent55cc34500e5abbfedb89adc95e3f94d53c544933 (diff)
downloadcpython-git-cf10a750f4b50b6775719cfb17bee00bc3a9c60b.tar.gz
bpo-35257: Avoid leaking LTO linker flags into distutils (GH-10900)
When compiling 3rd party C extensions, the linker flags used by the compiler for the interpreter and the stdlib modules, will get leaked into distutils. In order to avoid that, the PY_CORE_LDFLAGS and PY_LDFLAGS_NODIST are introduced to keep those flags separated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5c1c021920..349c927484 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1358,7 +1358,7 @@ if test "$Py_LTO" = 'true' ; then
fi
CFLAGS_NODIST="$CFLAGS_NODIST $LTOFLAGS"
- LDFLAGS="$LDFLAGS $LTOFLAGS"
+ LDFLAGS_NODIST="$LDFLAGS_NODIST $LTOFLAGS"
fi
# Enable PGO flags.
@@ -1518,6 +1518,7 @@ fi
AC_SUBST(BASECFLAGS)
AC_SUBST(CFLAGS_NODIST)
+AC_SUBST(LDFLAGS_NODIST)
# The -arch flags for universal builds on OSX
UNIVERSAL_ARCH_FLAGS=