summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZachary Ware <zachary.ware@gmail.com>2016-09-17 01:25:24 -0500
committerZachary Ware <zachary.ware@gmail.com>2016-09-17 01:25:24 -0500
commitf40d4ddff3c800b3c956a5e8820aabe3aa87cddd (patch)
treea5bf5ecfbbcb97a97573a326f5966d38de5fa49c /configure.ac
parent48ab735ca518b6cb3aef6ea1662182aba3f89253 (diff)
downloadcpython-git-f40d4ddff3c800b3c956a5e8820aabe3aa87cddd.tar.gz
Closes #27979: Remove bundled copy of libffi
An installed copy of libffi is now required for building _ctypes on any platform but OSX and Windows.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 21 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 767eacc1dc..8630eded32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2795,23 +2795,27 @@ AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
AS_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]),,,)
-case "$with_system_ffi" in
- "")
- case $ac_sys_system in
- Darwin)
- with_system_ffi="no"
- ;;
- *)
- with_system_ffi="yes"
- ;;
- esac
- ;;
- yes|no)
- ;;
- *)
- AC_MSG_ERROR([--with-system-ffi accepts no arguments])
- ;;
-esac
+if test "$ac_sys_system" = "Darwin"
+then
+ case "$with_system_ffi" in
+ "")
+ with_system_ffi="no"
+ ;;
+ yes|no)
+ ;;
+ *)
+ AC_MSG_ERROR([--with-system-ffi accepts no arguments])
+ ;;
+ esac
+ AC_MSG_RESULT($with_system_ffi)
+else
+ AC_MSG_RESULT(yes)
+ if test "$with_system_ffi" != ""
+ then
+ AC_MSG_WARN([--with(out)-system-ffi is ignored on this platform])
+ fi
+ with_system_ffi="yes"
+fi
if test "$with_system_ffi" = "yes" && test -n "$PKG_CONFIG"; then
LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"
@@ -2820,8 +2824,6 @@ else
fi
AC_SUBST(LIBFFI_INCLUDEDIR)
-AC_MSG_RESULT($with_system_ffi)
-
# Check for use of the system libmpdec library
AC_MSG_CHECKING(for --with-system-libmpdec)
AC_ARG_WITH(system_libmpdec,