summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorINADA Naoki <methane@users.noreply.github.com>2018-06-05 20:40:53 +0900
committerGitHub <noreply@github.com>2018-06-05 20:40:53 +0900
commite33648484775fa533fc8f1e5cc45f60061d29d54 (patch)
treeb849302a2a14c737ae813cd9e0c4185221c2d4be /configure.ac
parent5f48e2644dcfb47f0bbc0fcdc2b103a19bdec288 (diff)
downloadcpython-git-e33648484775fa533fc8f1e5cc45f60061d29d54.tar.gz
bpo-5755: Move -Wstrict-prototypes to CFLAGS_NODIST (GH-7395)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 20 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 189273daca..67cf817456 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1421,9 +1421,6 @@ if test "${OPT-unset}" = "unset"
then
case $GCC in
yes)
- if test "$CC" != 'g++' ; then
- STRICT_PROTO="-Wstrict-prototypes"
- fi
# For gcc 4.x we need to use -fwrapv so lets check if its supported
if "$CC" -v --help 2>/dev/null |grep -- -fwrapv > /dev/null; then
WRAP="-fwrapv"
@@ -1470,8 +1467,6 @@ then
;;
esac
- OPT="$OPT $STRICT_PROTO"
-
case $ac_sys_system in
SCO_SV*) OPT="$OPT -m486 -DSCO5"
;;
@@ -1678,6 +1673,26 @@ yes)
fi
AC_MSG_RESULT($ac_cv_enable_unreachable_code_warning)
+ AC_MSG_CHECKING(if we can turn on $CC strict-prototypes warning)
+ ac_save_cc="$CC"
+ CC="$CC -Werror -Wstrict-prototypes"
+ AC_CACHE_VAL(ac_cv_enable_enable_strict_prototypes_warning,
+ AC_COMPILE_IFELSE(
+ [
+ AC_LANG_PROGRAM([[]], [[]])
+ ],[
+ ac_cv_enable_strict_prototypes_warning=yes
+ ],[
+ ac_cv_enable_strict_prototypes_warning=no
+ ]))
+ CC="$ac_save_cc"
+ AC_MSG_RESULT($ac_cv_enable_strict_prototypes_warning)
+
+ if test $ac_cv_enable_strict_prototypes_warning = yes
+ then
+ CFLAGS_NODIST="$CFLAGS_NODIST -Wstrict-prototypes"
+ fi
+
AC_MSG_CHECKING(if we can make implicit function declaration an error in $CC)
ac_save_cc="$CC"
CC="$CC -Werror=implicit-function-declaration"