summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2016-09-07 12:00:06 -0700
committerBenjamin Peterson <benjamin@python.org>2016-09-07 12:00:06 -0700
commitd1702565855318d4c1984e997d973fc8d2f8a154 (patch)
treef22478f9186ed557348353e5db6a0ffd4ec47643 /configure.ac
parent7490577f6a7debf35bd13adf0f00fa9b272e8f8c (diff)
downloadcpython-git-d1702565855318d4c1984e997d973fc8d2f8a154.tar.gz
put -std=c99 in CFLAGS_NODIST
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3f723693d6..cd598f0b09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1458,8 +1458,6 @@ then
SCO_SV*) OPT="$OPT -m486 -DSCO5"
;;
esac
-
- OPT="$OPT -std=c99"
;;
*)
@@ -1478,6 +1476,8 @@ AC_SUBST(UNIVERSAL_ARCH_FLAGS)
# tweak BASECFLAGS based on compiler and platform
case $GCC in
yes)
+ CFLAGS_NODIST="$CFLAGS_NODIST -std=c99"
+
# Python doesn't violate C99 aliasing rules, but older versions of
# GCC produce warnings for legal Python code. Enable
# -fno-strict-aliasing on versions of GCC that support but produce