summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGregory P. Smith ext:(%20%5BGoogle%20Inc.%5D) <greg@krypto.org>2016-11-20 21:19:36 +0000
committerGregory P. Smith ext:(%20%5BGoogle%20Inc.%5D) <greg@krypto.org>2016-11-20 21:19:36 +0000
commitb9999158545f3bc089b926086daa666b8e4c7caa (patch)
treef61735e871e6edcc6df6ac1b01888df8cdaa7974 /configure.ac
parentd54d327f1c91c905f4c4efdb937a2cd745771c78 (diff)
downloadcpython-git-b9999158545f3bc089b926086daa666b8e4c7caa.tar.gz
Rename the new --with-optimiations flag to --enable-optimizations.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 8b694f01bd..f6ca54aa46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1370,8 +1370,8 @@ fi
AC_SUBST(DEF_MAKE_ALL_RULE)
AC_SUBST(DEF_MAKE_RULE)
Py_OPT='false'
-AC_MSG_CHECKING(for --with-optimizations)
-AC_ARG_WITH(optimizations, AS_HELP_STRING([--with-optimizations], [Enable expensive optimizations (PGO, maybe LTO, etc). Disabled by default.]),
+AC_MSG_CHECKING(for --enable-optimizations)
+AC_ARG_ENABLE(optimizations, AS_HELP_STRING([--enable-optimizations], [Enable expensive optimizations (PGO, maybe LTO, etc). Disabled by default.]),
[
if test "$withval" != no
then
@@ -1490,7 +1490,7 @@ case $CC in
LLVM_PROF_ERR=yes
if test "${REQUIRE_PGO}" = "yes"
then
- AC_MSG_ERROR([llvm-profdata is required for a --with-optimizations build but could not be found.])
+ AC_MSG_ERROR([llvm-profdata is required for a --enable-optimizations build but could not be found.])
fi
fi
;;
@@ -1506,7 +1506,7 @@ case $CC in
LLVM_PROF_ERR=yes
if test "${REQUIRE_PGO}" = "yes"
then
- AC_MSG_ERROR([llvm-profdata is required for a --with-optimizations build but could not be found.])
+ AC_MSG_ERROR([llvm-profdata is required for a --enable-optimizations build but could not be found.])
fi
fi
;;
@@ -4843,7 +4843,7 @@ if test "$Py_OPT" = 'false' -a "$Py_DEBUG" != 'true'; then
echo "" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
echo "If you want a release build with all optimizations active (LTO, PGO, etc),"
- echo "please run ./configure --with-optimizations" >&AS_MESSAGE_FD
+ echo "please run ./configure --enable-optimizations" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
fi