summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordoko@ubuntu.com <doko@ubuntu.com>2015-04-13 21:55:08 +0200
committerdoko@ubuntu.com <doko@ubuntu.com>2015-04-13 21:55:08 +0200
commit9e7ece271f37670a780ccdcd1c73019fde453d50 (patch)
tree4f19e4d10056cf90005877a5dd2536acf61eef53 /configure.ac
parent10657c08cbc613920e10ee44077f8ca71d0ca889 (diff)
downloadcpython-git-9e7ece271f37670a780ccdcd1c73019fde453d50.tar.gz
- Use PLATDIR for the platform directory everywhere (refactoring only)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d33df2a093..78fe3c785f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,7 +33,7 @@ if test "$cross_compiling" = yes; then
AC_MSG_ERROR([python$PACKAGE_VERSION interpreter not found])
fi
AC_MSG_RESULT($interp)
- PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/plat-$(MACHDEP) '$interp
+ PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/$(PLATDIR) '$interp
fi
elif test "$cross_compiling" = maybe; then
AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
@@ -493,6 +493,9 @@ then
fi
AC_MSG_RESULT($MACHDEP)
+AC_SUBST(PLATDIR)
+PLATDIR=plat-$MACHDEP
+
# And add extra plat-mac for darwin
AC_SUBST(EXTRAPLATDIR)
AC_SUBST(EXTRAMACHDEPPATH)