summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Felt <aixtools@users.noreply.github.com>2019-04-12 16:15:32 +0200
committerVictor Stinner <vstinner@redhat.com>2019-04-12 16:15:32 +0200
commit9d949f7796da612f1b588d18c6f041376992a9fc (patch)
tree63decb39986d71d9f431cf17d8806e511126b7a2 /configure.ac
parent9b8314cfe29ca532fc335277f6c36b72e6132922 (diff)
downloadcpython-git-9d949f7796da612f1b588d18c6f041376992a9fc.tar.gz
bpo-36588: On AIX, remove major version from sys.platform (GH-12787)
On AIX, sys.platform doesn't contain the major version anymore. Always return 'aix', instead of 'aix3' .. 'aix7'. Since older Python versions include the version number, it is recommended to always use sys.platform.startswith('aix').
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 880e47f70f..30e8587cb0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -404,6 +404,7 @@ then
MACHDEP="$ac_md_system$ac_md_release"
case $MACHDEP in
+ aix*) MACHDEP="aix";;
linux*) MACHDEP="linux";;
cygwin*) MACHDEP="cygwin";;
darwin*) MACHDEP="darwin";;