summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2015-07-03 15:30:54 +0200
committerStefan Krah <skrah@bytereef.org>2015-07-03 15:30:54 +0200
commit99e36b9a8475b3659194716e38a86832a508f2ac (patch)
tree090d5c30186ec8ef2b43f4560ac5cb9b865ac828 /configure.ac
parentd048003d909360faf716c84459ed7067bdee5f08 (diff)
downloadcpython-git-99e36b9a8475b3659194716e38a86832a508f2ac.tar.gz
Issue #24543: Use AC_LINK instead of AC_COMPILE in order to prevent false
positives with the -flto option (gcc >= 4.9.0 and clang).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c2a183005b..2c998b1ee9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3723,7 +3723,7 @@ fi
# so we try it on all platforms.
AC_MSG_CHECKING(whether we can use gcc inline assembler to get and set x87 control word)
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
+AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[
unsigned short cw;
__asm__ __volatile__ ("fnstcw %0" : "=m" (cw));
__asm__ __volatile__ ("fldcw %0" : : "m" (cw));