summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2014-08-22 13:30:59 -0700
committerNed Deily <nad@acm.org>2014-08-22 13:30:59 -0700
commit983df8688d6add6d7f35388eac97d5ecd1c8017f (patch)
tree6dc430b8624e77e59931b2bd3a43bff9f8db36a0 /configure.ac
parent01408453f12a1acd7c1b2caeca377d4bd6ea7947 (diff)
downloadcpython-git-983df8688d6add6d7f35388eac97d5ecd1c8017f.tar.gz
Issue #21166: Prevent possible segfaults and other random failures of
python --generate-posix-vars in pybuilddir.txt build target by ensuring that pybuilddir.txt is always regenerated when configure is run and that the newly built skeleton python does not inadvertently import modules from previously installed instances.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 54f8c0f69f..16da9f3999 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,6 +16,9 @@ AC_CANONICAL_HOST
AC_SUBST(build)
AC_SUBST(host)
+# pybuilddir.txt will be created by --generate-posix-vars in the Makefile
+rm -f pybuilddir.txt
+
if test "$cross_compiling" = yes; then
AC_MSG_CHECKING([for python interpreter for cross build])
if test -z "$PYTHON_FOR_BUILD"; then