summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorXiang Zhang <angwerzx@126.com>2018-08-20 23:15:07 +0800
committerGitHub <noreply@github.com>2018-08-20 23:15:07 +0800
commit95f9e14e33b713f35f5368acf7be56750bbdb5a8 (patch)
tree3f688a14bb0c4a331b722ae958ea2f80c86b1e5e /configure.ac
parentae1f0127298b1193618062fd0c8a3b434656e780 (diff)
downloadcpython-git-95f9e14e33b713f35f5368acf7be56750bbdb5a8.tar.gz
[2.7] bpo-30411: Use --git-dir instead of -C to make git work under version below 1.8.5. (GH-8744) (GH-8838)
(cherry picked from commit 4c8555773a801f957297132a92c0acb382d640e4)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 36625f7b82..257c8eb21e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1005,9 +1005,9 @@ HAS_GIT=no-repository
fi
if test $HAS_GIT = found
then
- GITVERSION="git -C \$(srcdir) rev-parse --short HEAD"
- GITTAG="git -C \$(srcdir) describe --all --always --dirty"
- GITBRANCH="git -C \$(srcdir) name-rev --name-only HEAD"
+ GITVERSION="git --git-dir \$(srcdir)/.git rev-parse --short HEAD"
+ GITTAG="git --git-dir \$(srcdir)/.git describe --all --always --dirty"
+ GITBRANCH="git --git-dir \$(srcdir)/.git name-rev --name-only HEAD"
else
GITVERSION=""
GITTAG=""