summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Panter <vadmium+py@gmail.com>2016-07-28 01:28:27 +0000
committerMartin Panter <vadmium+py@gmail.com>2016-07-28 01:28:27 +0000
commit801110b30319a8ab1f8f29eedbac3798b03afb55 (patch)
tree9ee01eba387e8d92656fccfb6db4780bce5a12d2 /configure.ac
parent2e1a34025cde19bddf12a2eac8fedb6afcca8339 (diff)
downloadcpython-git-801110b30319a8ab1f8f29eedbac3798b03afb55.tar.gz
Issue #27490: Do not build pgen when cross-compiling
The dependendency on the $(PGEN) variable must only be set when not cross-compiling. When cross-compiling, $(PGEN) will not be used, so no need to build it. Patch by Thomas Perl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f5e741d29b..c4dfe79053 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,12 +36,15 @@ if test "$cross_compiling" = yes; then
AC_MSG_RESULT($interp)
PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/$(PLATDIR) '$interp
fi
+ PGEN_DEPENDENCY=''
elif test "$cross_compiling" = maybe; then
AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
else
PYTHON_FOR_BUILD='./$(BUILDPYTHON) -E'
+ PGEN_DEPENDENCY='$(PGEN)'
fi
AC_SUBST(PYTHON_FOR_BUILD)
+AC_SUBST(PGEN_DEPENDENCY)
dnl Ensure that if prefix is specified, it does not end in a slash. If
dnl it does, we get path names containing '//' which is both ugly and