summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2016-09-08 11:39:42 +0200
committerChristian Heimes <christian@python.org>2016-09-08 11:39:42 +0200
commit7f9eb6eda30398ea7a5b630856abce81f91591f6 (patch)
treece478b6396042d42a7701169d5cd92594e9489f2 /configure.ac
parent81188246fabdb43efd26f34497131824f49cdc12 (diff)
downloadcpython-git-7f9eb6eda30398ea7a5b630856abce81f91591f6.tar.gz
Issue 28017: Use -std=gnu99 to get C99 with GNU extensions for bluetooth.h on big endian.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8a87945896..c57a94e4fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1523,7 +1523,9 @@ AC_SUBST(UNIVERSAL_ARCH_FLAGS)
# tweak BASECFLAGS based on compiler and platform
case $GCC in
yes)
- CFLAGS_NODIST="$CFLAGS_NODIST -std=c99"
+ # GNU dialect of C99, enables GNU extensions like __attribute__. GNU99
+ # is required by bluetooth.h on big endian machines.
+ CFLAGS_NODIST="$CFLAGS_NODIST -std=gnu99"
# Python doesn't violate C99 aliasing rules, but older versions of
# GCC produce warnings for legal Python code. Enable