summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2015-01-06 13:53:37 +0100
committerVictor Stinner <victor.stinner@gmail.com>2015-01-06 13:53:37 +0100
commit7c90667f74161c790227a2cb473c4e0c794ad884 (patch)
tree4c4ece5cbd42fad074369781a370df082930df16 /configure.ac
parent7ba8cdc31c2704f3c9017fb66ce14fc0983d68f8 (diff)
downloadcpython-git-7c90667f74161c790227a2cb473c4e0c794ad884.tar.gz
Issue #21356: Make ssl.RAND_egd() optional to support LibreSSL. The
availability of the function is checked during the compilation. Patch written by Bernard Spil.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 75486f46d8..d33df2a093 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2221,6 +2221,9 @@ AC_MSG_RESULT($SHLIBS)
# checks for libraries
AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
+AC_CHECK_LIB(crypto, RAND_egd,
+ AC_DEFINE(HAVE_RAND_EGD, 1,
+ [Define if the libcrypto has RAND_egd]))
# only check for sem_init if thread support is requested
if test "$with_threads" = "yes" -o -z "$with_threads"; then