summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorINADA Naoki <methane@users.noreply.github.com>2017-03-29 01:50:48 +0900
committerGitHub <noreply@github.com>2017-03-29 01:50:48 +0900
commit6a04ef7ceddae0930eba6cc57ba2ebfcef00abab (patch)
tree6f46da67449bf4a900855202a5e1703d69f14bdc /configure.ac
parentd6654071cf800ec9e7d4f3f169c123ec0149b243 (diff)
downloadcpython-git-6a04ef7ceddae0930eba6cc57ba2ebfcef00abab.tar.gz
bpo-29643: Fix check for --enable-optimizations (GH-873)
The presence of the ``--enable-optimizations`` flag is indicated by the value of ``$enableval``, but the configure script was checking ``$withval``, resulting in the ``--enable-optimizations`` flag being effectively ignored. (cherry picked from commit 8cea5929f52801b0ce5928b46ef836e99a24321a)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 85352fa761..5bd9b9d412 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1373,7 +1373,7 @@ Py_OPT='false'
AC_MSG_CHECKING(for --enable-optimizations)
AC_ARG_ENABLE(optimizations, AS_HELP_STRING([--enable-optimizations], [Enable expensive optimizations (PGO, maybe LTO, etc). Disabled by default.]),
[
-if test "$withval" != no
+if test "$enableval" != no
then
Py_OPT='true'
AC_MSG_RESULT(yes);